Jump to content
Sign in to follow this  
Reg

Tips: Avoid Too Much Transparency

Recommended Posts

Note that this tip follows on from the one linked below, but needs mentioning as it has an effect on the game if you use a mouse.  It is also good practice to get this right on the buttons ( as well as all the other lamps ).

I have taken a recent look at a layout from @BruceGeorge after a problem with clicking with the mouse on the Start button.  The problem was that the button would not always function on clicking when using a mouse.

Taking a look at the layout in design mode, it has shown the reason is simply - too much transparency has been used.  Here is the button in question...

170226_Button_Example.jpg

...it should not have all that grey in between the features and this also goes for all lamps.

Transparency within lamps causes two problems.

  1. Adjusting the brightness of the background and re-lamping does not work correctly.
  2. MFME will not click if using the mouse on the transparent areas of a button.

The fix is easy, ensure that your lamps are correctly masked for all lamps and buttons.  The above example should have really been looking like this...

170226_Button_Example_Good.jpg

...this is not going to be fixed on layouts that have been released so if you are suffering from this problem, ensure that you tick the Click All box as shown here.

170226_Button_Fix.jpg

...this means that the areas shown in red which are broken due to the over use of transparency will work fine.

This should only be used as a fix for current layouts, not a fix to avoid doing things correctly in the future.

Remember this applies to all lamps and if you do not, the following does not work correctly.

  1. Adjusting the brightness of the background and re-lamping does not work correctly.
  2. MFME will not click if using the mouse on the transparent areas of a button.

This is something that will be looked at in future reviews just to keep you on your toes! :)

However in some cases it might be possible to use the power of MFME to fix this for some legacy layouts.  On a backup to make sure you don't alter your original if you are not happy, go into DX Lamp Creator and click on Re Mask Images...

170226_Remask.jpg

...the broken Start button now looks like this.

170226_Button_Example_Remask.jpg

...MFME can save you some of the time, but please use best practices by ensuring it's right on release.


 "Maybe Reg is everywhere"                                                                                                                                                                                                                                              © 2020 Johnnyafc

Share this post


Link to post
Share on other sites

Evening Reg

I hope you're well

I'm a little confused by this so forgive me if this comes across very blonde

I can see the issue you have and I agree its not ideal on buttons but can you change that using the tools we have in MFME or do you have to marks those lamps yourself using the old ways of masking lamps because I can't see how you can pick and choose what it masks without masking each lamp one by one if it has this issue

Bruce

Share this post


Link to post
Share on other sites

Hi Bruce,

I am well, hope your good too. :)

That was fixed in MFME, but might not always be possible due to how layouts are done.

Go into DX Lamp Creator and click on Re Mask Images that does it in the case of your layout shown here.

Give it a shot on yours and you'll see it working.

Cheers.


 "Maybe Reg is everywhere"                                                                                                                                                                                                                                              © 2020 Johnnyafc

Share this post


Link to post
Share on other sites

Now that is interesting so what happens if doing that don't work do you have to mask each lamp one by one ?

Thanks for the tip again

 

Just going to update the file on Fruit Emu

 

Thanks :)

Share this post


Link to post
Share on other sites
Just now, BruceGeorge said:

Now that is interesting so what happens if doing that don't work do you have to mask each lamp one by one ?

Yes, that would have to be a manual fix.

But the power of MFME and that tool does so much for you I hope it'll be ok. :)


 "Maybe Reg is everywhere"                                                                                                                                                                                                                                              © 2020 Johnnyafc

Share this post


Link to post
Share on other sites

How were you doing it before, "Magic Wand" in an external program and then importing ?


 "Maybe Reg is everywhere"                                                                                                                                                                                                                                              © 2020 Johnnyafc

Share this post


Link to post
Share on other sites

No I was using that tool Reg but I would click Dx layout creator and then i would add a on image and click lamp wizard then click create all I think doing that and then clicking Re mask images after cleans it up so I wasn't using that last bit its funny without the hints you and other give I still find new little things the tools do with every layout you make to be honest the new MFME still blows me away its just fun playing about with the tools sod the machines lol

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...